EqLlyHJ5w6,694hQRgLWm

三层交换机VLAN通信配置

三层交换机VLAN通信配置

【实训背景】

企业有两个主要部门,技术部和销售部,分别在不同的办公室,为了安全和便于管理对两个部门的主机进行了VLAN的划分,技术部和销售部分处于不同的VLAN。现由于业务的需求需要销售部和技术部的主机能够相互访问,获得相应的资源,两个部门的交换机通过一台三层交换机进行了连接。

【实训目的】

掌握三层交换机基本配置方法、掌握三层交换机VLAN路由的配置方法

【技术原理】

在交换网络中,通过VLAN对一个物理网络进行了逻辑划分,不同的VLAN之间是无法直接访问的,必须通过三层的路由设备进行连接。一般利用路由器或三层交换机来实现不同VLAN之间的互相访问。三层交换机和路由器具备网络层的功能,能够根据数据的IP 包头信息,进行选路和转发,从而实现不同网段之间的访问。

直连路由是指:为三层设备的接口配置IP地址,并且激活该端口,三层设备会自动产 生该接口IP所在网段的直连路由信息。

三层交换机实现VLAN互访的原理是,利用三层交换机的路由功能,通过识别数据包 的IP地址,查找路由表进行选路转发。三层交换机利用直连路由可以实现不同VLAN之 间的互相访问。三层交换机给接口配置IP地址,采用SVI (交换虚拟接口)的方式实现 VLAN间互连。SVI是指为交换机中的VLAN创建虚拟接口,并且配置IP地址。

【实训内容】

1、按照拓扑进行网络连接

2、二层交换机配置相应VLAN和Trunk

3、配置三层交换机的路由功能

4、测试

【实现功能】

使在同一VLAN里的计算机系统能跨交换机进行相互通信,而在不同VLAN里的计算机系统也能进行相互通信。

【实训设备】

S2126(2台),S3760(1台)、直连线(4条)、PC(2台)

【实训拓扑】


【实训步骤】


1、在交换机SwitchB 上创建 Vlan 10,并将 E0/3 端口划分到 Vlan 10 中。

[SwitchB]vlan 10

[SwitchB-vlan10]port e0/3

[SwitchB-vlan10]quit

[SwitchB]dis vlan all

2、在交换机SwitchC上创建 Vlan 20,并将 E0/3 端口划分到 Vlan 20 中。

[SwitchC]vlan 20

[SwitchC-vlan20]port e0/3

[SwitchC-vlan20]quit

[SwitchC]dis vlan all


3、在交换机 SwitchB 、 SwitchC 与交换机SwitchA相连的端口(E0/1、 E0/2端口)定义为 Trunk 模式。

[SwitchB]interface ethernet0/1

[SwitchB-Ethernet0/1]port link-type trunk

[SwitchB-Ethernet0/1]port trunk permit vlan all


[SwitchC]interface ethernet0/2

[SwitchC-Ethernet0/2]port link-type trunk

[SwitchC-Ethernet0/2]port trunk permit vlan all

[SwitchC-Ethernet0/2]quit


4、在交换机 SwitchA 上将与 SwitchB、 SwitchC相连的端口(E0/1、 E0/2 端口)定义为Trunk 模式。

[SwitchA]interface ethernet0/1

[SwitchA-Ethernet0/1]port link-type trunk

[SwitchA-Ethernet0/1]port trunk permit vlan all


[SwitchA]interface ethernet0/2

[SwitchA-Ethernet0/2]port link-type trunk

[SwitchA-Ethernet0/2]port trunk permit vlan all

[SwitchA-Ethernet0/2]quit


5、设置PC1IP地址:192.168.10.1 255.255.255.0

设置PC2IP地址:192.168.20.1 255.255.255.0

验证 PC1 与 PC2不能互相通信。


6、设置三层交换机 VLAN 间通讯。

在交换机 SwitchA 上创建Vlan 10、 Vlan 20 并配置IP地址

[SwitchA]vlan 10

[SwitchA-vlan10]quit

[SwitchA]vlan 20

[SwitchA-vlan10]quit

[SwitchA]int vlan 10

[SwitchA-Vlan-interface10]ip address 192.168.10.254 255.255.255.0

[SwitchA-Vlan-interface10]undo shutdown

[SwitchA-Vlan-interface10]quit


[SwitchA]int vlan 20

[SwitchA-Vlan-interface20]ip address 192.168.20.254 255.255.255.0

[SwitchA-Vlan-interface20]undo shutdown


7、将 PC1的默认网关设置为 192.168.10.1,将 PC2 的默认网关设置为:192.168.20.1。

8、测试结果。不同 VLAN 内的主机可以互相PING通。


EqLlyHJ5w6