EqLlyHJ5w6,694hQRgLWm

思科三层交换机实现不同VLAN间互相访问配置

来源:济南磐龙笔记本交换机维修作者:济南磐龙思科交换机维修网址:http://www.pldtwx.com

思科三层交换机实现不同VLAN间互相访问配置


案例解决:思科二层交换机不具备三层交换能力,无法在两个VLAN之间提供路由,为了解决这一问题,就必须增加思科路由器或思科三层交换机之类的路由设备。我们这里选择增加一台思科三层交换机来实现(可以实现VLAN间路由,同时可提供更多的接口来接入主机)。

思科三层交换机VLAN间路由配置步骤:

1、配置干道(TRUNK)
在接口模式下声明该接口为trunk模式的命令格式:
Switch(config-if)#switchport mode turnk
指定接口封装类型的命令格式:
Switch(config-if)#switchport trunk encapsulation {dot1q|ISL}
注:dot1q封装类型为802.1q,一般在交换机默认封装dot1q类型

2、配置VLAN
在私有模式下进入vlan database声明VLAN的命令格式:
Switch#vlan database
Switch(vlan)#vlan vlan_number
进入相应接口,将该接口划分到指定VLAN内的格式:
Switch(config-if)#switch port mode access
Switch(config-if)#switchport access vlan vlan_number

3、配置VLAN间路由
思科三层交换机的路由模块和交换模块直接通过思科交换机的背板总线连接,因此只需要在三层交换机的路由模块上定义与VLAN数量相当的逻辑接口,并和VLAN对应,然后为这些接口分配IP地址即可。
首先要在在思科三层交换机上打开路由功能,命令格式如下:
Switch(config)#ip routing
为VLAN分配地址的命令格式如下:
Switch(config)#interface vlan vlan_number
Switch(config)#ip add ip_adress netmask

思科三层交换机VLAN间路由配置实例:
设备:思科二层交换机(cisco 2960)A、B,思科三层交换机一台(cisco 3560),主机四台:主机1、主机2、主机3、主机4。

二层交换机A配置:
!
Swith(config)#hostname switch-a(定义二层交换机为switch-a)
!
Switch-a#vlan database
Switch-a(vlan)#vlan 2 (定义VLAN 2)
Switch-a(vlan)#vlan 3 (定义VLAN 3)

Switch-a(config)#interface fe0/1
Switch-a(config-if)#switchport mode trunk(定义该端口为trunk口,与三层交换机连接)

Switch-a(config)#interface fe0/2(定义该端口为trunk口,与二层交换机B连接)
Switch-a(config-if)#switchport mode trunk

Switch-a(config)#interface fe0/3
Switch-a(config-if)#switchport access vlan 2(端口划入VLAN1,连接主机2)

Switch-a(config)#interface fe0/4
Switch-a(config-if)#switchport access vlan 3(端口划入VLAN2,连接主机3)

二层交换机B配置:
!
Swith(config)#hostname switch-b (定义二层交换机为switch-b)
!
Switch-b#vlan database
Switch-b(vlan)#vlan 2 (定义VLAN 2)
Switch-b(vlan)#vlan 3 (定义VLAN 3)

Switch-b(config)#interface fe0/1
Switch-b(config-if)#switchport mode trunk(定义该端口为trunk口,与三层交换机连接)

Switch-b(config)#interface fe0/2(定义该端口为trunk口,与二层交换机A连接)
Switch-b(config-if)#switchport mode trunk

Switch-b(config)#interface fe0/3
Switch-b(config-if)#switchport access vlan 2(端口划入VLAN1,连接主机3)

Switch-b(config)#interface fe0/4
Switch-b(config-if)#switchport access vlan 3(端口划入VLAN2,连接主机4)

三层交换机配置:
!
Swith(config)#hostname switch-c(定义三层交换机为switch-c)
!
Switch-c(config)#ip routing(打开三层交换机的路由功能)
!
Switch-c#vlan database
Switch-c(vlan)#vlan 2 (定义VLAN 2)
Switch-c(vlan)#vlan 3 (定义VLAN 3)

Switch-c(config)#interface vlan 2
Switch-c(config-if)#ip address 192.168.2.1 255.255.255.0(为VLAN2配置IP)
Switch-c(config-if)#no shut(启用VLAN2)
!
Switch-c(config)#interface vlan 3
Switch-c(config-if)#ip address 192.168.3.1 255.255.255.0(为VLAN3配置IP)
Switch-c(config-if)#no shut(启用VLAN3)
!
主机配置:
主机1、3分配192.168.2.0网段地址,网关为:192.168.2.1
主机2、4分配192.168.3.0网段地址,网关为:192.168.3.1

配置完成后,两个VLAN(VLAN2、VLAN3)就可以通过三层交换机进行通信了。

在分别属于不同VLAN的主机(1、2、3、4)之间使用ping命令测试VLAN间路由配置的正确性。能ping通即表示两个不同VLAN 之间实现通信。


EqLlyHJ5w6