EqLlyHJ5w6,694hQRgLWm

华为路由器实验教程

来源:济南磐龙笔记本交换机维修作者:济南磐龙维修网址:http://www.pldtwx.com


华为路由器实验教程




华为路由器实验教程!济南磐龙维修


实验一 计算机和交换机基本设置

添加一个交换机,一个计算机,双击交换机,进入终端配置:

<Quidway>system

password:

[Quidway]sysname S3026                      ;交换机命名

[S3026]super password 111                     ;设置特权密码

[S3026]user-interface vty 0 4

[S3026-ui-vty0-4]authentication-mode password

[S3026-ui-vty0-4]set authentication-mode password simple 222

[S3026-ui-vty0-4]user privilege level 3

[S3026-ui-vty0-4]quit

[S3026]quit

<S3026>sys

password:111

[S3026]display currect-config

[S3026]dis curr


[S3026]vlan 2

[S3026-vlan2]port ethernet0/2

[S3026-vlan2]port e0/4 to et0/6

[S3026-vlan2]quit

[S3026]dis vlan

[S3026]int e0/3

[S3026-Ethernet1]port access vlan 2

[S3026-Ethernet1]quit

[S3026]dis vlan

[S3026]dis curr


[S3026]interface vlan 1

[S3026-Vlan-interface1]ip address 10.65.1.8 255.255.0.0

[S3026-Vlan-interface1]quit

[S3026]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2

[S3026]ip default-gateway 10.65.1.2

[S3026]dis curr

[S3026]save

双击小电脑:

login:root

password:linux

[root@PCA root]#ifconfig eth0 10.65.1.1 netmask 255.255.0.0

[root@PCA root]#ifconfig

[root@PCA root]#route add default gw 10.65.1.2

[root@PCA root]#route


[root@PCA root]#ping 10.65.1.8

[root@PCA root]#telnet 10.65.1.8


华为路由器实验教程!济南磐龙维修

实验二 配置端口聚合

要求聚合的端口工作在全双工,速度一致,在同一槽口且连续。

参数:ingress:MAC, both:源和目的MAC

对于SwitchA:

[SwitchA]interface ethernet0/1

[SwitchA-Ethernet0/1]duplex full

[SwitchA-Ethernet0/1]speed 100


[SwitchA-Ethernet0/1]int e0/2

[SwitchA-Ethernet0/2]duplex full

[SwitchA-Ethernet0/2]speed 100


对于SwitchB:

[SwitchB]interface ethernet0/1

[SwitchB-Ethernet0/1]duplex full

[SwitchB-Ethernet0/1]speed 100


[SwitchB-Ethernet0/1]int e0/2

[SwitchB-Ethernet0/2]duplex full

[SwitchB-Ethernet0/2]speed 100


聚合操作:

[SwitchA]link-aggregation ethernet0/1 to ethernet0/2 both

[SwitchB]link-aggregation ethernet0/1 to ethernet0/2 both


[SwitchA]display link-aggregation ethernet0/1

[SwitchA]undo link-aggregation all

华为路由器实验教程!济南磐龙维修

实验三 基本VLAN设置

[SwitchA]vlan 2

[SwitchA-vlan2]port e0/3 to e0/4

[SwitchA]vlan 3

[SwitchA-vlan3]port e0/5 to e0/6


[SwitchB]vlan 2

[SwitchB-vlan2]port e0/3 to e0/4

[SwitchB]vlan 3

[SwitchB-vlan3]port e0/5 to e0/6

设置计算机的IP为:

PCA:10.65.1.1  PCB:10.66.1.1  PCC:10.65.1.3  PCD:10.66.1.3


[root@PCA root]#ping 10.65.1.1     (本机IP)

[root@PCA root]#ping 10.65.1.3  不通 (中间连接线是vlan 1)

[root@PCA root]#ping 10.66.1.1  不通 (不同网络,不同vlan)

[root@PCA root]#ping 10.66.1.3  不通 (不同网络,不同vlan)

[root@PCB root]#ping 10.66.1.3  不通 (中间连接线是vlan 1)


PCA改接到SwitchA E0/2 (vlan 1)

[root@PCA root]#ping 10.65.1.3  不通 (同网络,不同vlan)


PCC改接到SwitchB E0/2 (vlan 1)

[root@PCA root]#ping 10.65.1.3    (同网络,同在vlan 1)


再改回来,并设置trunk:

[S3026A]interface ethernet 0/8

[S3026A-Ethernet0/8]port link-type trunk

[S3026A-Ethernet0/8]port trunk permit vlan all


[S3026B]interface ethernet 0/1

[S3026B-Ethernet0/1]port link-type trunk

[S3026B-Ethernet0/1]port trunk permit vlan all


[root@PCA root]#ping 10.65.1.3  

[root@PCA root]#ping 10.66.1.3  不通

[root@PCB root]#ping 10.66.1.3  

即:PCAPCC同在vlan 2 是通的,PCBPCD同在vlan 3是通的。

   PCAPCB是不通的。同理PCCPCD也是不通的。


   再加入一个交换机switchC,将它串入switchAswitchB之间,连接方式:

   switchA:E0/8-->switchC:E0/3; switchC:E0/6-->switchB:E0/1


(1) 新加入的SwitchC 默认状态时,测试连通性。

   PCA->PCC,从PCB->PCD 测试:

[root@PCA root]# ping 10.65.1.3 (不通)

[root@PCB root]# ping 10.66.1.3 (不通)


   由于新加入的交换机没有设置trunk,所有接口默认vlan 1,对于交换机而言,

trunk 要成对出现,如果dot1q不能和另一端交换信息会自动down掉。


(2) 将交换机之间的连线都设置成trunk时,再测试连通性。


[S3026C]interface ethernet0/3

[S3026C-Ethernet0/1]port link-type trunk

[S3026C-Ethernet0/1]port trunk permit vlan all


[S3026C]interface ethernet0/6

[S3026C-Ethernet0/8]port link-type trunk

[S3026C-Ethernet0/8]port trunk permit vlan all


现在有两条正确的trunk,再看一下联通情况:


[root@PCA root]# ping 10.65.1.3 (通)

[root@PCB root]# ping 10.66.1.3 (通)


(3) 设置vtp

   VTPvlan 传输协议,在VTP Server上配置的vlan 在条件允许条件下,可以

VTP Client 端看到VTP Server上的vlan,并将自己端口加入到vlan中。


[S3026C]vtp domain abc

[S3026C]vtp mode server

[S3026C]vtp password ok


[S3026B]vtp domain abc

[S3026B]vtp mode client

[S3026B]vtp password ok


[S3026A]#disp vlan

[S3026B]#disp vlan

[S3026C]#disp vlan

   当口令和域名一致时,client端可以学习到server端的vlan,在VTP Server端还

可以有很多策略,这里只是说明最基本的问题。

   VTP在企业、机关、学校的应用是很多的,在主交换机上设置好vlan以后,下级的

交换机不用再设置vlan,可以将client的某些端口添加到VTP Server中定义的vlan

去,加强了管理。


华为路由器实验教程!济南磐龙维修

实验四  配置primary VLANsecondary VLAN


   主附vlan一般用于一个网络段的情况,主vlan和子vlan间可以访问,

而子vlan之间是不能访问的。


[SwitchA]vlan 2

[SwitchA-vlan2]port ethernet 0/5 to ethernet 0/6


[SwitchA]vlan 3

[SwitchA-vlan3]port ethernet 0/7 to ethernet 0/8


[SwitchA]vlan 5

[SwitchA-vlan5]port ethernet 0/1 to ethernet 0/4

[SwitchA-vlan5]isolate-user-vlan enable          ;vlan5是主vlan

[SwitchA-vlan5]quit


[SwitchA]isolate-user-vlan 5 secondary 2,3       ;vlan2,3是子vlan


[SwitchB]vlan 2

[SwitchB-vlan2]port ethernet 0/5 to ethernet 0/6


[SwitchB]vlan 3

[SwitchB-vlan3]port ethernet 0/7 to ethernet 0/8


[SwitchA]vlan 4

[SwitchB-vlan4]port ethernet 0/1 to ethernet 0/4

[SwitchB-vlan4]isolate-user-vlan enable          ;vlan4是主vlan

[SwitchB-vlan4]quit


[SwitchB]isolate-user-vlan 4 secondary 2,3       ;vlan2,3是子vlan

华为路由器实验教程!济南磐龙维修

实验五 交换机的镜像与生成树

() 设置镜像

镜像是一个端口的数据被映射到另一个端口,进行数据分析。

[Quidway]monitor-port e0/8

[Quidway]port mirror e0/1

或:

[Quidway]port mirror e0/1 to e0/2 observing-port e0/8

() 生成树

[Quidway]stp {enable|disable}

[Quidway]stp priority 4096               设置交换机的优先级

[Quidway]stp root primary                设置交换机为树根

[Quidway-Ethernet0/1]stp cost 200        设置交换机端口的花费


华为路由器实验教程!济南磐龙维修

实验六  路由器BootROM升级

<Quidway>system

[Quidway]reload

Press Ctrl+B to enter Boot Menu …

Boot Menu:

1:Download application program

2:Download Bootrom program

3:Modify Bootrom password

4:Exit menu

5:Reboot


 Enter your choice(1-5):1


Downloading application program

from serial ... (rs232)

please choose your download speed:

1:9600bps

2:19200bps

3:38400bps

4:Exit and reboot

 Enter your choice(1-4):2

Download speed is 38400bps.

Please change the terminal's speed to 38400bps.

And select XMODEM

protocol. Press ENTER key when ready.

Downloading ...CC   (please select [File]->[Send])

############################################################

############################################################

############################################################

########### ok!

Download completed.

Write flash auccessfully!

[Quidway]


华为路由器实验教程!济南磐龙维修

实验七  直联路由

<Quidwqy>system

password:

[Quidway]interface ethernet0

[Quidway-Ethernet0]ip addr 10.65.1.2 255.255.255.0

[Quidway-Ethernet0]undo shutdown

[Quidway-Ethernet0]int e1

[Quidway-Ethernet1]ip addr 10.66.1.2 255.255.255.0

[Quidway-Ethernet1]undo shutdown


[root@PCA root]#ifconfig eth0 10.65.1.1 netmask 255.255.0.0

[root@PCB root]#ifconfig eth0 10.66.1.1 netmask 255.255.0.0


[root@PCA root]#ping 10.65.1.2  (通,没有关只能ping直连的口)

[root@PCA root]#ping 10.66.1.2  (不通,PCA 没有设置网关)


[root@PCA root]#route add default gw 10.65.1.2

[root@PCA root]#ping 10.66.1.2  ()

[root@PCA root]#ping 10.66.1.1  (不通,因PCB没有网关)


[root@PCB root]#route add default gw 10.66.1.2

[root@PCA root]#ping 10.66.1.1  ()


去掉计算机Host BRouter的连线,再ping

[root@PCA root]#ping 10.66.1.2 不通(没有接线端口会自动down)


再连接Host BRouter的连线,再ping:

[root@PCA root]#ping 10.66.1.2 ()



华为路由器实验教程!济南磐龙维修

实验八 单臂路由

设置PCA ip:10.65.1.1 gateway:10.65.1.2

设置PCB ip:10.66.1.1 gateway:10.66.1.2

1.一个接口两个IP的情况

<Quidwqy>system

password:

[Quidway]interface ethernet0

[Quidway-Ethernet0]ip addr 10.65.1.2 255.255.255.0

[Quidway-Ethernet1]ip addr 10.66.1.2 255.255.255.0 secondary

[Quidway-Ethernet1]undo shutdown


[root@PCA root]#ping 10.66.1.1


2.划分两个子接口,对两个vlan的路由

[SwitchA]vlan 2

[SwitchA-vlan2]port e0/3

[SwitchA]vlan 3

[SwitchA-vlan3]port e0/6

[SwitchA]ine e0/1

[SwitchA-Ethernet0/1]port link-type trunk

[SwitchA-Ethernet0/1]port trunk permit vlan all

[SwitchA-Ethernet0/1]port trunk encap dot1q

[SwitchA]dis curr


[Quidway]int e0

[SwitchA-Ethernet0]int e0.1

[SwitchA-Ethernet0.1]encapsulation dot1q 2

[SwitchA-Ethernet0.1]ip addr 10.65.1.2 255.255.255.0

[SwitchA-Ethernet0.1]nudo shut

[SwitchA-Ethernet0.1]int e0.2

[SwitchA-Ethernet0.2]encapsulation dot1q 2

[SwitchA-Ethernet0.2]ip addr 10.66.1.2 255.255.255.0

[SwitchA-Ethernet0.2]nudo shut

[SwitchA]dis curr


[root@PCA root]#ping 10.66.1.1



华为路由器实验教程!济南磐龙维修

实验九 静态路由实验

PCA:10.65.1.1  PCB:10.66.1.1  PCC:10.70.1.1  PCD:10.71.1.1


[RouterA]interface ethernet0

[RouterA-Ethernet0]ip addrress 10.65.1.2 255.255.0.0

[RouterA-Ethernet0]undo shutdown

[RouterA-Ethernet0]int e1

[RouterA-Ethernet1]ip addrress 10.66.1.2 255.255.0.0

[RouterA-Ethernet1]undo shutdown

[RouterA-Ethernet1]int s1

[RouterA-Serial1]ip addrress 10.68.1.2 255.255.0.0

[RouterA-Serial1]undo shutdown

[RouterA-Serial1]clock rate 64000

[RouterA-Serial1]quit

[RouterA]ip routing

[RouterA]dis curr


[RouterB]interface ethernet0

[RouterB-Ethernet0]ip addrress 10.70.1.2 255.255.0.0

[RouterB-Ethernet0]undo shutdown

[RouterB-Ethernet0]int e1

[RouterB-Ethernet1]ip addrress 10.71.1.2 255.255.0.0

[RouterB-Ethernet1]undo shutdown

[RouterB-Ethernet1]int s0

[RouterB-Serial0]ip addrress 10.68.1.1 255.255.0.0

[RouterB-Serial0]undo shutdown

[RouterB-Serial0]quit

[RouterB]ip routing

[RouterB]dis curr


[root@PCA root]#ifconfig eth0 10.65.1.1 netmask 255.255.0.0

[root@PCA root]#route add default gw 10.65.1.2


[root@PCA root]#ping 10.65.1.2

[root@PCA root]#ping 10.66.1.2

[root@PCA root]#ping 10.67.1.2

[root@PCA root]#ping 10.68.1.2 不通

[root@PCA root]#ping 10.69.1.2 不通


[RouterA]ip route-static 10.69.0.0 255.255.0.0 10.67.1.1

[root@PCA root]#ping 10.69.1.1


三个路由器的静态路由 (参考实验九图)


   设置RouterAIP:

f0/0: 10.65.1.2  --->PCA:10.65.1.1

f0/1: 10.66.1.2  --->PCB:10.66.1.1

s0/0: 10.67.1.2

s0/1: 10.68.1.2  --->RouterC s0/0


   设置RouterCIP:

s0/0: 10.68.1.1  <---

s0/1: 10.78.1.2  --->RouterB s0/0


   设置RouterBIP:

s0/0: 10.78.1.1  <---

s0/1: 10.67.1.1

f0/0: 10.69.1.2  --->PCC:10.69.1.1

f0/1: 10.70.1.2  --->PCD:10.70.1.1


   设置从PCAPCC的静态路由

ROA(config)#ip routing

ROA(config)#ip route 10.69.0.0 255.255.0.0 10.68.1.1

ROA#show ip route

ROB(config)#ip route 10.69.0.0 255.255.0.0 10.78.1.1

ROB#show ip route

[root@PCA root]#ping 10.69.1.1 ()

[root@PCA root]#ping 10.78.1.1 (不通)

[root@PCA root]#ping 10.70.1.1 (不通)


   为什么PCA 10.78.1.1不通呢?它是去10.69.1.1要经过的地方啊,这是由于在

RouterA上,没有去10.78.0.0网络的路由,所以到这个网络它不知道要向哪去送。


   如何让PCA10.70.1.1 (PCD)通呢,像10.69.0.0网络一样,在路径的路由器上

再各写一条到10.70.0.0网络的静态路由就可以了。

   如果每一条路径都写一组静态路由显然不好,由于PCA在这个网络中实际只有一条

主通路,所以使用默认路由较好。


   我们再做一个使用默认路由的小实验,先去掉原有的静态路由。

ROA(config)#no ip route 10.69.0.0 255.255.0.0 10.68.1.1

ROA#sh ip ro


ROB(config)#no ip route 10.69.0.0 255.255.0.0 10.78.1.1

ROB#sh ip ro


[root@PCA root]#ping 10.69.1.1 (不通)


ROA(config)#ip route 0.0.0.0. 0.0.0.0 10.68.1.1

ROA#sh ip ro


ROB(config)#ip route 0.0.0.0. 0.0.0.0 10.69.1.1

ROB#sh ip ro


[root@PCA root]#ping 10.69.1.1 ()

[root@PCA root]#ping 10.70.1.1 ()

[root@PCA root]#ping 10.78.1.1 ()


   路由表是路由器实现路由的指导思想。到一个网络通不通,要看路由表中有没有去

目的网络的路由表项,动态路由可以自动创建路由表,定时更新。


[RouterB-Serial0]undo ip addrress 10.67.1.1 255.255.0.0

[RouterB-Serial0]ip addrress 10.70.1.1 255.255.0.0


[RouterC]interface serial0

[RouterC-Serial0]ip addrress 10.67.1.1 255.255.0.0

[RouterC-Serial0]undo shutdown

[RouterC-Serial0]clock rate 64000

[RouterC-Serial0]int s1

[RouterC-Serial1]ip addrress 10.70.1.1 255.255.0.0

[RouterC-Serial1]undo shutdown

[RouterC-Serial1]quit

[RouterC]ip route-static 10.69.0.0 255.255.0.0 10.70.1.1

[RouterC]dis curr


[root@PCA root]#ping 10.69.1.1

[root@PCA root]#ping 10.68.1.1 不通



华为路由器实验教程!济南磐龙维修

实验十  动态路由实验

[RouterA]rip version 2 multicast

[RouterA-rip]network 10.0.0.0               ;可以用all

[RouterA-rip]ip routing


[RouterB]rip version 2 multicast

[RouterB-rip]network 10.0.0.0

[RouterB-rip]ip routing


[RouterC]rip version 2 multicast

[RouterC-rip]network 10.0.0.0

[RouterC-rip]ip routing

[RouterC]dis ip route


[root@PCA root]#ping 10.69.1.1

[root@PCA root]#ping 10.70.1.1


[RouterA-rip]peer 10.68.1.1                  ;指明交换点

[RouterA-rip]summary                         ;聚合

[RouterA-Serial0]rip split-horizon           ;水平分隔

[RouterA]rip work

[RouterA]rip input

[RouterA]rip output

[Quidway]router id A.B.C.D                   ;配置路由器的ID


[Quidway]ospf enable                         ;启动OSPF协议

[Quidway-ospf]import-route direct            ;引入直联路由

[Quidway-Serial0]ospf enable area 0          ;配置OSPF区域

[Quidway-Serial0]link-protocol ppp



华为路由器实验教程!济南磐龙维修

实验十一  访问控制列表实验


1.基本访问列表

[RouterC]firewall enable

[RouterC]firewall default permit


[RouterC]acl 10

[RouterC-acl-10]rule normal deny source 10.65.1.1

[RouterC-acl-10]rule normal permit source any

[RouterC]int s0

[RouterC-Serial0]firewall packet-filter 10 inbound

[RouterC-Serial0]quit

[RouterC]display acl


[root@PCA root]#ping 10.69.1.1 不通

[root@PCB root]#ping 10.69.1.1


[RouterC]undo acl 10

[RouterC]display acl


[root@PCA root]#ping 10.69.1.1

[root@PCB root]#ping 10.69.1.1

[RouterC]acl 11

[RouterC-acl-11]rule normal deny source 10.65.1.1 0.0.0.255

[RouterC-acl-11]rule normal permit source any

[RouterC]int s0

[RouterC-Serial0]firewall packet-filter 11 inbound

[RouterC]display acl


[root@PCA root]#ping 10.69.1.1 不通

[root@PCB root]#ping 10.69.1.1 不通


[RouterC]undo acl 11


2.扩展访问控制列表


[RouterC]firewall enable

[RouterC]firewall default permit

[RouterC]acl 101

[RouterC-acl-101]rule deny tcp source 10.65.1.1 0 destination 10.69.1.1

0

[RouterC-acl-101]rule permit ip source any destination any

[RouterC]int s1

[RouterC-Serial1]firewall packet-filter 101 outbound

[RouterC-Serial1]quit

[RouterC]dis acl


[root@PCA root]#ping 10.69.1.1 不通

[root@PCA root]#ping 10.70.1.1

[root@PCB root]#ping 10.69.1.1


[RouterC]undo acl

[root@PCA root]#ping 10.69.1.1





华为路由器实验教程!济南磐龙维修

实验十二  地址转换配置


设置公司三个公网IP133.0.0.1133.0.0.2133.0.0.3 。为地址池pool

内部网络10.1.0.0网络可以通过公网IP访问外部计算机。自动转换成公网IP


设置:

Host A :  10.1.1.1 255.255.0.0

Host B :  10.1.1.2 255.255.0.0

Host C :  10.1.1.3 255.255.0.0

Host D :  10.2.1.1 255.255.0.0


RouterA E0: 10.1.1.9 255.255.0.0

Host F :  133.0.0.8 255.255.0.0


[Quidway]nat address-group 133.0.0.1 133.0.0.3 pool1


[Quidway]acl 1

[Quidway-acl-1]rule permit source 10.1.0.0 0.0.255.255

[Quidway-acl-1]rule deny source any

[Quidway-acl-1]int s0

[Quidway-Serial0]undo shut

[Quidway-Serial0]nat outbound 1 address-group pool1


[Quidway-Serial0]nat server global 133.0.0.1 inside 10.1.1.1 ftp tcp

[Quidway-Serial0]nat server global 133.0.0.2 inside 10.1.1.2 www tcp

Quidway-Serial0]nat server global 133.0.0.3 inside 10.1.1.3 smtp udp



济南磐龙笔记本交换机维修,专业芯片级维修服务商 www.pldtwx.com

EqLlyHJ5w6